User Tools

Site Tools


ru:upgrade_5_to_6

Обновление Sparky с 5 до 6

Это должно работать без проблем, но помните: вы делаете это на свой страх и риск!

Чтобы сделать dist обновление от Sparky 5 до 6, сделайте:

1. Backup your personal files to external disk or partition.

2. Поменять репозитории Debian с buster на bullseye в файле:

/etc/apt/sources.list

Должно выглядеть так:

deb http://deb.debian.org/debian bullseye main contrib non-free
deb-src http://deb.debian.org/debian bullseye main contrib non-free
deb http://security.debian.org/debian-security/ bullseye-security/updates main contrib non-free
deb-src http://security.debian.org/debian-security/ bullseye-security/updates main contrib non-free
deb http://deb-multimedia.org/ bullseye main non-free

3. Поменяйте Sparky репозитории с nibiru на potolo в файле:

/etc/apt/sources.list.d/sparky.list

Должно выглядеть так:

deb https://repo.sparkylinux.org/ core main
deb-src https://repo.sparkylinux.org/ core main
deb https://repo.sparkylinux.org/ potolo main
deb-src https://repo.sparkylinux.org/ potolo main

4. Обновить список пакетов:

sudo apt update

5. Установите пакет sparky-apt_YYYYMMDD~sparky6 & sparky-core_6.YYYYMMDD, который должен удалить пакет sparky5-apt:

sudo apt install sparky-apt sparky-core

6. Обновить список пакетов снова:

sudo apt update

7. И обновление дистрибутива:

sudo apt full-upgrade

Если возникнут проблемы:

sudo dpkg-reconfigure -a
sudo apt install -f
This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
ru/upgrade_5_to_6.txt · Last modified: 2021/07/15 20:50 by pavroo