User Tools

Site Tools


repository_oldoldstable

Sparky Oldoldstable Repositories

Sparky of the oldoldstable line is based on and uses Debian “oldoldstable” packages.

Repository

Users of Debian “oldoldstable” branch should add Sparky tyche and core repositories to get access to Sparky repos:

 sudo nano /etc/apt/sources.list.d/sparky.list

and paste into the file:

 deb https://repo.sparkylinux.org/ tyche main
 deb-src https://repo.sparkylinux.org/ tyche main
 deb https://repo.sparkylinux.org/ core main
 deb-src https://repo.sparkylinux.org/ core main

Create a preference file:

 sudo nano /etc/apt/preferences.d/sparky

and paste into the file:

 Package: *
 Pin: release o=SparkyLinux
 Pin-Priority: 1001

Otherwise, install 'sparky-apt' and 'sparkyX-apt' (X=Sparky Version Number; 4,5, or 6) packages to do so.

Public key

Download the Sparky's Public Key as a “deb” package from:

https://repo.sparkylinux.org/pool/main/s/sparky-keyring/

Then install it:

 sudo dpkg -i /path/to/sparky-keyring_VERSION_all.deb
 sudo apt-key add /usr/share/keyrings/sparky.gpg.key

or get the key manually ('wget' has to be installed):

 wget -O - https://repo.sparkylinux.org/sparky.gpg.key | sudo apt-key add -

Make sure you have 'apt-transport-https' package installed (Sparky up to 4.x only).

This website uses cookies. By using the website, you agree with storing cookies on your computer. Also you acknowledge that you have read and understand our Privacy Policy. If you do not agree leave the website.More information about cookies
repository_oldoldstable.txt · Last modified: 2021/08/17 12:00 by pavroo