User Tools

Site Tools


upgrade_5_to_6

Differences

This shows you the differences between two versions of the page.

Link to this comparison view

upgrade_5_to_6 [2020/03/30 23:04]
pavroo created
upgrade_5_to_6 [2020/03/30 23:08]
pavroo
Line 1: Line 1:
-===== Aktualizacja ​Sparky ​do 6 =====+===== Upgrade ​Sparky ​from to 6 =====
  
 <WRAP center info 100%> <WRAP center info 100%>
-Powinno zadziałać bez problemówlecz pamiętajRobisz to na własne ryzyko!+It should work with no problemsbut rememberYou do that on your own risk!
 </​WRAP>​ </​WRAP>​
  
-Aby zaktualizować ​Sparky 5 do 6:+To make dist upgrade from Sparky 5 to do:
  
-1. Wykonaj kopię zapasową swoich osobistych plików na zewnętrzny dysk lub partycję.+1. Backup your personal files to external disk or partition.
  
-2. Zmień repozytoria Debiana z **buster** ​na **bullseye**, w pliku:+2. Change Debian repositories from **buster** ​to **bullseye** ​at the file:
  
    /​etc/​apt/​sources.list    /​etc/​apt/​sources.list
  
-Zawartość pliku powinna wyglądać jak poniżej:+So it should look like that:
  
    deb http://​deb.debian.org/​debian bullseye main contrib non-free    deb http://​deb.debian.org/​debian bullseye main contrib non-free
Line 21: Line 21:
    deb http://​deb-multimedia.org/​ bullseye main non-free    deb http://​deb-multimedia.org/​ bullseye main non-free
  
-3. Zmień repozytoria ​Sparky ​**nibiru** ​na **potolo**, w pliku:+3. Change ​Sparky ​repositories from **nibiru** ​to **potolo** ​at the file:
  
    /​etc/​apt/​sources.list.d/​sparky.list    /​etc/​apt/​sources.list.d/​sparky.list
  
-Zawartość pliku powinna wyglądać jak poniżej:+So it should look like that:
  
    deb https://​repo.sparkylinux.org/​ core main    deb https://​repo.sparkylinux.org/​ core main
Line 32: Line 32:
    ​deb-src https://​repo.sparkylinux.org/​ potolo main    ​deb-src https://​repo.sparkylinux.org/​ potolo main
  
-4. Odśwież ​listę pakietów:+4. Refresh package ​list:
  
    sudo apt update    sudo apt update
  
-5. Zainstaluj pakiet ​**sparky6-apt**, który musi usunąc ​**sparky5-apt**:​+5. Install ​**sparky6-apt** ​package which has to remove ​**sparky5-apt**:​
  
    sudo apt install sparky6-apt    sudo apt install sparky6-apt
  
-6. Ponownie odśwież ​listę pakietów:+6. Refresh package ​list again:
  
    sudo apt update    sudo apt update
  
-7. Wykonaj aktualizację dystrybucji:+7. Dist upgrade now:
  
    sudo apt full-upgrade    sudo apt full-upgrade
  
-Jeśli wystąpi jakiś ​problem:+If any problem ​run:
  
    sudo dpkg-reconfigure -a    sudo dpkg-reconfigure -a
    sudo apt install -f    sudo apt install -f
  
upgrade_5_to_6.txt · Last modified: 2020/03/30 23:08 by pavroo